우분투 NGINX PPA 문제, N: Skipping acquire of configured file ‘nginx/binary-i386/Packages’

|

오랜만에 우분투 서버에 접속해 서버을 업데이트하는데 갑자기 이상한 메세지가 뜹니다. 다른것은 문제가 없는데 i386관련 한가지만 안된다는 메세지입니다.

Reading package lists... Done
N: Skipping acquire of configured file 'nginx/binary-i386/Packages' as repository 'http://nginx.org/packages/mainline/ubuntu bionic InRelease' doesn't support architecture 'i386'

우분투 서버에서 사용하는 i386이란

이게 무슨 의미일까요? i386이 무엇을 의미일까요? 설마 예전 2~30년전에 사용했던 386컴퓨터를 의미하는 것일까요?

인터넷 검색, 요즘에는 구글 검색이라고 많이 표현하더군요.. 네이버가 맛이 많이 갔어..

암튼 구글 검색 결과 창아보니이렇게 설명하더군요.

리눅스 배포판이나 패키지를 다운 받을 때 보면은 i386, i586, x86, x86_64 등등 여러가지 가 있는 것을 볼 수 있는데 각 소스 코드를 각 CPU 에 적합하게 컴파일한 결과를 다운 받아 사용할 수 있도록 한 것입니다.

“각 CPU에 맞게끔 컴파일해 놓은 것이 없다면 사용자가 소스 코드를 받아서 일일이 다 컴파일하는 수고를 해야 합니다. 이런 수고를 덜어주기 위해서 i386, i586, x86, x86_64 등등의 버전이 있는 것 입니다.”

문제 원인을 무엇일까? -우분투 PPA 수정

아무튼 서버 업데이트 시 이런 메세지가 나왔던 것은 제가 적용하고 있던 NGINX 업데이트 본은 제공하는 PPA에서 더이상 이 패키지를 지원하지 않기 때문이라도 하네요.

NGINX PPA 주소리스트는 아래 파일에서 관리하는 아시죠.

nano /etc/apt/sources.list

제가 사용하던 NGINX 업데이트를 위한 PPA는 아래 주소를 사용했었는데요.

deb http://nginx.org/packages/mainline/ubuntu/ bionic nginx
deb-src http://nginx.org/packages/mainline/ubuntu/ bionic nginx

이를 아래 주소로 변경해주면 됩니다.
보시면 [arch=amd64]만 추가되었는데요. 64비트 서버이므로 64비트에 해당되는 것만 업데이트해서 불필요한 요청을 하지 않토록 하는 것 같습니다.

deb [arch=amd64] http://nginx.org/packages/mainline/ubuntu/ bionic nginx
deb-src http://nginx.org/packages/mainline/ubuntu/ bionic nginx

만약 NGINX 안정판만 사용한다면 다음 주소를 사용하면 됩니다.

deb [arch=amd64] http://nginx.org/packages/ubuntu/ bionic nginx
deb-src http://nginx.org/packages/ubuntu/ bionic nginx

이러면 “N: Skipping acquire of configured file ‘nginx/binary-i386/Packages’같은 메세지 없이 원활히 업데이트 됩니다.